Results 1 to 2 of 2

Thread: Red Light on Waterpik R7 won't go off

  1. #1
    Join Date
    Apr 2006
    Posts
    174

    Default Red Light on Waterpik R7 won't go off

    Recently I changed filters (R-7) and have run gallons& gallons of
    water through it and the light still blinks orange. Now it is
    blinking red and this is unlike the first filter (which came with
    the WaterPic unit). Is it defective? Have I done something wrong? As
    long as I've let it run it surely should be blinking green by now.
    Please advise. Thanks!

  2. #2
    Roxanne is offline Senior Member
    Join Date
    Apr 2006
    Posts
    232

    Default How to make the Red Light go off...

    Quote Originally Posted by FiltersFastEmailQuestions
    Recently I changed filters (R-7) and have run gallons& gallons of
    water through it and the light still blinks orange. Now it is
    blinking red and this is unlike the first filter (which came with
    the WaterPic unit). Is it defective? Have I done something wrong? As
    long as I've let it run it surely should be blinking green by now.
    Please advise. Thanks!
    You will need to reset your WaterPik unit. All you need to do is
    remove the new water filter cartridge. There should be a battery
    underneath that cartridge. Simply remove the battery for thirty
    (30) minutes and then put it back in. This alerts the unit that you
    are replacing the filter. The light should then go back to green.
    Roxanne Crawford
    FiltersFast
    www.filtersfast.com
    866-438-3458

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •