Results 1 to 5 of 5

Thread: R8 filters experience unusually poor water flow after only 1.5 months.

  1. #1
    Yesod is offline Junior Member
    Join Date
    Nov 2009
    Posts
    2

    Exclamation R8 filters experience unusually poor water flow after only 1.5 months.

    I have a three month old F8 system that looses virtually all water flow after each new filter in just 1.5 months. I purchased two water filters and they both experienced the same phenomenon; after only a month and a half, water dribbles out the faucet at a rate of 250ml every 80 seconds (that's nearly a minute and a half to fill one cup of water!). The indicator light on the F8 has always been green by the time the R8 filters suddenly experience this drastic drawback.

    Please advice on the issue as I cannot imagine that the tap water is -- that -- dirty to clog the faucet filter.

    --
    Yesod

  2. #2
    Andy CWS is offline Moderator
    Join Date
    Dec 2006
    Location
    Port Clinton, Ohio, United States
    Posts
    750

    Default

    Can you give more detail on what an F8 filter is? Is there a link you send us to?

    Andy

  3. #3
    Yesod is offline Junior Member
    Join Date
    Nov 2009
    Posts
    2

  4. #4
    Andy CWS is offline Moderator
    Join Date
    Dec 2006
    Location
    Port Clinton, Ohio, United States
    Posts
    750

    Default

    OK,OK. I don't do much with thise filters. Low water flow usually indicates blocakage due to sediment but other easons may be involved.
    Andy

  5. #5
    katie is offline Junior Member
    Join Date
    Aug 2007
    Posts
    22

    Default

    Hi, Instapure Waterpik suggests the R8 to be replaced every 100 gallons however that number can and will vary depending on water quality. If you only used let's say 3 gallon per day then the filter will last about 33 days.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •