Results 1 to 2 of 2

Thread: Help wanted ero 392

  1. #1
    billydream is offline Junior Member
    Join Date
    Oct 2006
    Posts
    1

    Default Help wanted ero 392

    This is my first post your help would be greatly appreciated. I have a ecowater system ero 392, water is leaking out of the automatic shutoff cap on the main canister. I changed both diaghragms and tightened up to the mark. Also i can only fill one cup of water at a time.

  2. #2
    Roxanne is offline Senior Member
    Join Date
    Apr 2006
    Posts
    232

    Default Leaking RO System

    Quote Originally Posted by billydream
    This is my first post your help would be greatly appreciated. I have a ecowater system ero 392, water is leaking out of the automatic shutoff cap on the main canister. I changed both diaghragms and tightened up to the mark. Also i can only fill one cup of water at a time.
    Hi,

    Although we do not carry your system I was able to locate a manual for it. From what I can tell there are a few parts that may be causing the leak and the flow problem. Here is a link to the product manual. I would look into possibly getting a new shut off valve and flow control. Unfortunately I do not know where you could purchase these. My honest suggestion would be to look into a newer system. Reverse Osmosis Technology has come a long way since your system was created. Here are some links to more updated RO systems:

    APRO5500
    RO-3500
    Roxanne Crawford
    FiltersFast
    www.filtersfast.com
    866-438-3458

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •