Results 1 to 6 of 6

Thread: Membrane filter

  1. #1
    M41
    M41 is offline Junior Member
    Join Date
    Jun 2011
    Posts
    3

    Default Membrane filter

    I replaced the membrane filter in my Hydrotech model 12402 system less than 3 months ago and the water production is now down to less than 1/2 gallon/day. This is the second replacement in approx 1 year. Any suggestions? thanks.

  2. #2
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    190

    Default

    how is the air pressure in the tank? is the RO on hard or soft water and if it's not treated has it ever been tested? IE: what's in your water?

  3. #3
    M41
    M41 is offline Junior Member
    Join Date
    Jun 2011
    Posts
    3

    Default

    Thanks for the response. I checked the tank pressure about 2 months ago and it was 8lb PSI. Will check it again. I have hard water with a PPM of 385

  4. #4
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    190

    Default

    hard water is a bad thing for an RO. the membrane removes calcium...but that same calcium covers it and plugs it up causing more frequent replacements. that may be what its happening to you...but without being there to check it out I can't say for sure.

  5. #5
    M41
    M41 is offline Junior Member
    Join Date
    Jun 2011
    Posts
    3

    Default

    If I change the membrane filter from a 25GPD to a 45GPD shouldn't that increase the time before the next change?

  6. #6
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    190

    Default

    the better option for the long run would be to get a softener installed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •