Results 1 to 7 of 7

Thread: Kinetico gx running to drain

  1. #1
    PlumberZach is offline Junior Member
    Join Date
    Oct 2011
    Posts
    6

    Default Kinetico gx running to drain

    This has new filters, I replaced the quick fill valve on top of the water tank. It is producing water but constantly making this woosh sound and pulsating water out of the drain. Anyone have some suggestions on how to fix this from constantly running to drain?

  2. #2
    PlumberZach is offline Junior Member
    Join Date
    Oct 2011
    Posts
    6

    Default

    I should have gave a little bit more info. This is on city water where I am testing it. I disconnected feed line #1 from another thread said it can bleed the air from the tank if there is any present. When I put the system back online. It still pulsed when running to drain. I am sure the WoW tank is full.

  3. #3
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    192

    Default

    Try another tank module. Check the bladder while you have the tank opened up to make sure it isn't bound up...IE it spins freely...and while you're at it check for holes.

  4. #4
    PlumberZach is offline Junior Member
    Join Date
    Oct 2011
    Posts
    6

    Default

    Are you talking a A200 tank assembly or just the quick flow valve. Because I already inspected the quick flow valve and inspected the bladder and saw nothing.

  5. #5
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    192

    Default

    you won't "see" anything in the module. There are 2 spring loaded pistons inside. A visual inspection of them won't tell you much. If/when the one goes bad it won't move properly and won't allow the water to flow normally. The most frequent sign is little flow initially with it resuming normal flow if you wait long enough. But, any flow issues will 9 times out of 10 be a result of module failure...most often due to putting filters on dry though age and other factors work on them as well. If the othe rpiston goes bad it won't open and close correctly and will usually stick open and run to the drain. If you have a Kinetico dealer nearby I'd recommend upgrading to the K5 unit to get away from the issue...and get better flow, cartridge options and a 10 year warranty while you're at it.
    Last edited by pawaterguy; 10-27-2011 at 05:33 PM.

  6. #6
    PlumberZach is offline Junior Member
    Join Date
    Oct 2011
    Posts
    6

    Default

    We converted it to a water over air tank. And now its working fine.

  7. #7
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    192

    Default

    Sorry to hear that. Glad you have a working RO again, though.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •