Results 1 to 5 of 5

Thread: Kinetico RO membrane question

  1. #1
    Gman is offline Junior Member
    Join Date
    Mar 2011
    Posts
    8

    Default Kinetico RO membrane question

    I am wondering about the life expectancy of the membrane in a Kinetico VX deluxe system.I am at about 9 years now and two days ago developed a slight taste in the ro water.Filters are about half way through the life cycle and always changed when needed.TDS test says the ro water is at 37 which according to the scale on my meter is good. 0-50 is the range.
    The company that sold Kinetico is no more and there is no service within hundreds of miles/kms to help.
    Any input would be great.
    Thanks

  2. #2
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    196

    Default

    You're looking for a 90% or better reduction, so you need to know the house water TDS to compare. 0-50 being "good" is a bit misleading. If your raw TDS is 100 and you're reading 40 then the unit isn't doing much and I'd hardly call that "good". Compare the cold tap water against the RO water and you'll get a better idea of what kind of shape the membrane is in. Also, has the unit been sanitized lately? If it's been years since it's been sanitized you could have some issues in the tank that need addressing. I've seen TDS creep up on units that weren't sanitized on a regular (yearly) basis quicker than units that were maintained regularly. Anyway, test the water as mentioned earlier and post the results and we can give you a more informed opinion on the condition of the membrane.

  3. #3
    Gman is offline Junior Member
    Join Date
    Mar 2011
    Posts
    8

    Default

    Found the problem late last night.I remember reading the RO system needs 40 psi or better to operate correct.My house is on a well system.The main pressure tank and pump switch is set at 42 psi on off and up to 60 psi off.The gauge that was on the line was plugged and reading 45 psi all the time.When I replaced the gauge and tested.I found the switch had gotten weak or somehow backed off to 30 psi.Turned the switch settings back up and the taste in the RO water is gone.
    The TDS on the regular water in the house post softener is 430.So the RO reading 37 should do me ok I believe.
    I will take your advice and sanitize this weekend.Hasn't been done in about 18 months.
    Thanks for the reply.

  4. #4
    Andy CWS is offline Moderator
    Join Date
    Dec 2006
    Location
    Port Clinton, Ohio, United States
    Posts
    750

    Default

    Is your water softened? That membrane automatically cleans itself when the tank tops off. Is your tank white or black? depending on circumstances, that membrane may be within acceptable production ranges up to 20 years.
    Last edited by Andy CWS; 03-31-2012 at 05:57 AM.

  5. #5
    Gman is offline Junior Member
    Join Date
    Mar 2011
    Posts
    8

    Default

    Yes the water is softened.Kinetico softener was installed at the same time as the RO.Its the VX Deluxe ro and has the black tank.I checked the ro TDS again now that the system has had the water fully flushed out 3 times.I always drain the RO completely and put the water into a glass storage bottle for faster pouring and easy filling of the pets water bowls.The TDS is at 24 on the RO water and the pre ro water is reading 430 that has been softened.
    I love the Kinetico systems except for the retail service part of life.The only local dealer stopped selling and servicing them about 4 years back.So I had to learn what makes these things work and how to fix them.The filters I bus in from another city but parts are another story.
    The drain on the RO was sticking aver a year back and I pulled things apart.Very simple stuff inside.I was able to get the identical grooved o-rings for the modulator at a local heavy duty hydraulic supply store.A simple cleaning and sanitizing along with new lube and the system was back to normal for less than 2 dollars and some of my time.Working great again now that the system pressure is where it should be.
    Any feedback to what I have done is always welcome either good or bad.
    Thanks again

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •