Results 1 to 5 of 5

Thread: culligan ac30 low water pressure

  1. #1
    bobc is offline Junior Member
    Join Date
    Mar 2009
    Posts
    3

    Default culligan ac30 low water pressure

    I am having low pressure with my ro system. I havent changed the filters in about 3 years so I assume this is the problem.
    Should I replace the membrane too? it is quite expensive comared to the other 3 filters.

    I also put about ten pounds of pressure in the storage tank thinking this might help, is that the right amount?. Now i get a water for a few seconds then nothing, after a few hours a few seconds of water and then nothing. Is this all related to the filters??
    Last edited by bobc; 03-15-2009 at 06:20 PM.

  2. #2
    Andy CWS is offline Moderator
    Join Date
    Dec 2006
    Location
    Port Clinton, Ohio, United States
    Posts
    750

    Default

    I think those units recommend filter changes every six months and membrane is warrantied for a year. So, yes, get those done.

    But the pressure problem you describe sounds like the tank is water-logged...bladder is broken. Is it a white, plastic tank or a metal one?

    10psi is not too much. 7-9 is typical for a three-gallon tank.

    Andy Christensen, CWS-II

  3. #3
    bobc is offline Junior Member
    Join Date
    Mar 2009
    Posts
    3

    Default

    It is a white metal storage tank, looks like 2 gallons. If the bladder is broken shouldn't water come out of the shrader valve if I press it? Would it be okay to put 15 or 20 lbs of pressure in it?

  4. #4
    bobc is offline Junior Member
    Join Date
    Mar 2009
    Posts
    3

    Default

    anyone????

  5. #5
    pjfan is offline Junior Member
    Join Date
    May 2009
    Posts
    4

    Default

    Quote Originally Posted by bobc
    It is a white metal storage tank, looks like 2 gallons. If the bladder is broken shouldn't water come out of the shrader valve if I press it? Would it be okay to put 15 or 20 lbs of pressure in it?
    Don't do this. I recently pumped about 20 PSI into my tank. The first problem is that the water will not get full as the pressure is too high. The other problem that I just experienced is that my waste water does not stop flowing out anymore. I am trying to figure out what is causing it.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •