Results 1 to 3 of 3

Thread: GE FQSVF runs slow?

  1. #1
    DaddySS is offline Junior Member
    Join Date
    Aug 2009
    Posts
    1

    Default GE FQSVF runs slow?

    I replaced my dual stage undersink filter and now it runs slow? I tried reinstalling about five different ways - water off, water on, one a ta time, etc. and it still runs slow?

  2. #2
    JimRR is offline Junior Member
    Join Date
    Oct 2009
    Posts
    1

    Default Filter runs slow

    I have a different filter but mine also runs slow after changing the filters cartridges. I tried all the things you tried - no luck!

    My guess is that there is a valve built into the part that the cartridges screw onto that keeps the water from squirting out when the filter cartridges are removed. I think this valve has probably been stuck partially closed. I can't think of any way to fix that - and it's only a guess in the first place. I hope somebody with some real insight gives us a reply.

  3. #3
    Alex is offline Senior Member
    Join Date
    Mar 2009
    Posts
    434

    Default Try at your own risk!

    The system's manifold has a small black button inside the filter receiver. When you tighten the filter in, it has 'ramps' that pushes the manifold's black button to open the water valves. The problem is that the 'ramps' are too low and does not push the button all the way in.

    You can take pliers and squeeze (not too much!) the ramps inside the filter, so they will raise a little. It will be enough to push the button to open the flow completely.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •