Results 1 to 2 of 2

Thread: Need Help setting up Kinetico Model 50

  1. #1
    heliman08 is offline Junior Member
    Join Date
    Apr 2011
    Location
    Hometead,Florida
    Posts
    1

    Default Need Help setting up Kinetico Model 50

    Hello, I am new to this forum. I just recently acquired a re-certified Kinetico Model 50 water softener. I need help on how to set it up to use in my house. I am on city water 2ppm of chlorine and 11 grains of hardness coming in. Right now it has a #2 disk on it. I am assuming that is the right disk for my water conditions, but i need the brine tank settings. It currently uses the hexagonal brine tank. I also want to use KCl instead of NAcl. I would appreciate if some one could help me.

  2. #2
    Andy CWS is offline Moderator
    Join Date
    Dec 2006
    Location
    Port Clinton, Ohio, United States
    Posts
    747

    Default

    Yes, a #2 disc is proper. Your salt tank should be set at 1 pound per regen. What size tank (dimensions)? is the brine tank? The brine tank is probably already set from the previous owner unless it was reset sometime. Any particular reason to go with KCl? Your water's sodium content will be extremely low with salt.

    Chlorine should be removed with a carbon prefiltration adequate for flow rate and longevity. Get a chlorine test kit---cheap and easy to use.

    Andy Christensen, CWS-II

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •