Results 1 to 11 of 11

Thread: Autotrol 460i help needed please!

  1. #1
    stevow is offline Junior Member
    Join Date
    Nov 2011
    Posts
    4

    Default Autotrol 460i help needed please!

    Hi all,

    I have an autotrol 460i water softerner that I am having problems with at the moment and wondered if any of you had any experience with this machine>?.

    the probem is that it is nearly full up with water to the drain level, I have cleaned the injector and filter and also the air valve, the 2 main flappers looked alright but did have a gentle imprint of the shut off valve on them so I turned them around.

    I re-started the machine as per the manufacturers guidelines and the water level about the salt should be approx an 1" above it, but it kept rising to just under the drain off level, is there any likely simple fixes to this machine, please bear with me, but this type of machine is new to me so is abit of a learing curve!.

    Many thanks for any guidance and advice.

    Stevo

  2. #2
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    194

    Default

    Did the water go down at all when it cycled? Before it came back up that is.

  3. #3
    stevow is offline Junior Member
    Join Date
    Nov 2011
    Posts
    4

    Default

    Hiya pawaterguy,

    Thanks for your reply, no the water didnt go down at all just kept rising when it was cycling and dropped a small amount afterwards.

  4. #4
    biermech is offline Junior Member
    Join Date
    Oct 2011
    Posts
    11

    Default

    It sounds as if there is no brine draw. Does the unit have an air check mounted on the side of it? If so, put the unit into a drawn cycle and disconnect the brine tubing from the air check. If it is drawing brine, the check ball should drop.

  5. #5
    pawaterguy is offline Senior Member
    Join Date
    Mar 2010
    Posts
    194

    Default

    Clean the injector screens...don't forget the one on the left. As the previous poster mentioned...sounds like you have no brine draw. Those screens are the first line of defense. If they get fouled up or clogged you'll get no brine draw (the pulling of the salt water out of the tank into the main tank). If you have a ball check system also make sure it's working. Manually cycle the thing if you know how and watch to make sure it drops when it should and rises when it should. That can be a sign of certain issues. One of which can be as simple as a hole int he brine line which is easily fixed by replacing the brine tubing between the salt tank and the head. But, it's a matter of a process of elimination til you know what it is you're fixing.

  6. #6
    stevow is offline Junior Member
    Join Date
    Nov 2011
    Posts
    4

    Default

    Hi pawaterguy, thanks for the reply. Sorry I've been busy to have a look at the watersoftener, but had a chance lastnight and replaced the piping to the brine tubing between the salt tank and the head and also the brine line into the tank and it still is filling up. The injector has been cleaned and also the filter. I think there might be a problem perhaps with the aircheck as the ball is constantly floating in whatever cycle the machine is in. Could the flapper valves be a problem as well?.

    Biermech, what is the drawn cycle on this unit - as I'm not sure what one that is on the valve head, I did however disconnect the line in all functions and the ball never dropped at all, so it seems as if it's not drawing the brine and done the above checks on it.

    Thanks again for any pointers chaps.
    Last edited by stevow; 11-11-2011 at 07:42 AM.

  7. #7
    stevow is offline Junior Member
    Join Date
    Nov 2011
    Posts
    4

    Default

    Hi, I was just writing to see if anyone could help me out on this one please?, many thanks for any advice or pointers to getting it working again.
    Cheers all

  8. #8
    biermech is offline Junior Member
    Join Date
    Oct 2011
    Posts
    11

    Default

    If the unit will not draw brine, than the injector and/or the flappers need to be replaced.

  9. #9
    CWilson is offline Junior Member
    Join Date
    Jan 2012
    Location
    Liberty Hill, TX
    Posts
    2

    Default

    I'm no expert, but I recently had this same problem. Truns out my brine line was getting air in the line and would not draw brine water . Since my setup was brand new I never thought about checking the line between the unit and the brine tank. I did however remove all the connections from the ball check to the inside of the brine tank. I found a couple different types of ferules on the connections. Through trial and error I was able to fill a bucket with water and drop the brine line inside the bucket and reconfigure the connections until I had the ferules setup so that the connections were air tight. Finally I was able to make the system "draw" from the bucket/brine tank. I was able to replace some of the ferules and in the end got an air tight system. Mine is working as designed now. Sorry I can't be more specific I'm learning as I go. This is my first water softener ever and I now have 3 whole months experience with it.

  10. #10
    biermech is offline Junior Member
    Join Date
    Oct 2011
    Posts
    11

    Default

    Congrads. You found a place that has all answers you seek. I started in the water treatment industry in RR. I have friends still in the area one of which lives in Liberty Hill.

  11. #11
    CWilson is offline Junior Member
    Join Date
    Jan 2012
    Location
    Liberty Hill, TX
    Posts
    2

    Default

    Quote Originally Posted by biermech View Post
    Congrads. You found a place that has all answers you seek. I started in the water treatment industry in RR. I have friends still in the area one of which lives in Liberty Hill.
    Do you still live in the area? I could really use some help in the Hardness, Capcity and Salt Dial settings on my unit. Is there a way I could send you the details of what I have and maybe get some advice?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •